Auteur Sujet: Sauvetage TGS100 SVP  (Lu 3697 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne gerardlso

  • Nouveau membre
  • *
  • Messages: 7
Sauvetage TGS100 SVP
« le: 01 Juillet 2011 à 10:00:57 »
Bonjour à tous, j'ai bien suivi le fil http://www.doume59.net/forum/index.php?topic=3727.0 d'OCHALA mais je n'y trouve pas la solution à mon problème.

Donc voilà suite à un orage mon TGS100 ne démarre plus mais n'est pas mort. Il était configuré comme suit :
- Flash = officielle 2.0.11
- iBoot
- DOUME 2.0.11 et Juliet 2.011 en SD

Dans cette config il me donnait toute satisfaction et je n'ai jamais tenté de l'upgrader en DOUME 2.0.15r2 par exemple.

Suite à l'orage, j'ai tenté de le reflasher :
- via une image totale MMC : échec
- via CC2.4 et un lien NULL modem : dernière DAGS 2.0.22 full cad U-boot + image : transfert + erase + flash = done MAIS il est toujours planté
- via CC2.4 et un lien NULL modem : dernière DOUME 2.0.15r2 full cad U-boot + image : transfert + erase + flash = done MAIS il est toujours planté
- via CC2.4 et un lien NULL modem : image noboot : transfert + erase + flash = done MAIS il est toujours planté

Avec Hyperterminal j'observe le démarrage de U-boot (que je connais assez bien pour en avoir dérivé 2 versions pour 2 cartes différentes) :
- il démarre correctement mais se plaint :
  -> le CRC des variable d'environement n'est pas bon : il recharge donc des variables "par défaut"
  -> il ne trouve pas les fichiers init.denc.uboot.cmp et init.denc.uboot.rgb
- il charge l'image Linux correctement :
  -> Verifying Checksum ... OK : donc Linux en Flash est correct et sa recopie en DDR est correcte
  -> Uncompressing Kernel Image ... OK : la décompression image DDR -> exec DDR s'est bien déroulée, l'étape suivante est JUMP LINUX
- aucune trace du démarrage Linux !
- on peut prendre la main dans le boot loader :
  -> avec CTRL+z j'ai le prompt
  -> je peux créer une variable d'environnement pipo et la sauvarger : au prochain reboot, il n'y a plus d'erreur de CRC ENV
  -> je peux dumper le kernel qui semble effectivement bon et qui commence bien par la date de naissance de Wolfgang DENX (merci à lui au passage pour U-boot)

A ce stade mon feeling est que :
- le HW est correct
- U-boot est en 1.1.2 du 22 Octobre 2009 et est correct
- le kernel Linux semble intègre
- je ne suis pas certain des variables ENV de U-boot hors elles conditionnent beaucoup de choses dont les arguments de lancement de Linux
- je ne sais rien des autres partitions en particulier de la RFS qui correspond à /dev/mtdblock3 et sans elle Linux merde

J'ai donc besoin de l'aide d'une personne qui possède un TGS100 et qui pourrait me fournir les éléments suivants :
- la liste des variables ENV de U-boot : c'est simple mais je devrai les entrer manuellement
- l'image kernel TGS100_kernel.img
- l'image RFS TGS100_root.img
- tout ce à quoi je n'aurais pas pensé

Je suis persuadé que DOUME pourrait m'aider et je l'en remercie par avance, mais toute aide serait la bienvenue car je l'aime bien mon TGS100 !

A bientôt je l'espère,

MG






Hors ligne Doume

  • The Boss
  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 6.090
  • Administrateur
    • Doume
Re: Sauvetage TGS100 SVP
« Réponse #1 le: 01 Juillet 2011 à 10:52:49 »
Si j'en avais la possibilité, je ne manquerais pas d'essayer de t'aider, mais :
- Je suis actuellement en congés à 1000 Km de chez moi, et je ne me connecte que rarement
- Je n'ai plus aucun ITGate à ma disposition pour inventorier les variables d'environnement du bootloader, ni faire le moindre test.

Mais je ne doute pas qu'un autre membre viendra à ton secours
J'ai tous les droits, je suis chez moi.
Au moindre non-respect des règles, je vire les importuns.

Hors ligne gerardlso

  • Nouveau membre
  • *
  • Messages: 7
Re: Sauvetage TGS100 SVP
« Réponse #2 le: 01 Juillet 2011 à 11:53:23 »
Merci DOUME pour ta réponse.

C'est la vie, l'Itgate n'est plus une machine moderne et beaucoup d'utilisateurs sont passés à autre chose.

Effectivement si un possesseur averti d'un TGS100 peut m'aider se serait bien, je n'aimerais pas avoir à me débarrasser de cette machine uniquement parce que je n'ai pas de quoi restaurer son logiciel.

A++

MG

Hors ligne MiKe

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 5.863
    • Doume Forum
Re: Sauvetage TGS100 SVP
« Réponse #3 le: 01 Juillet 2011 à 15:14:17 »
Yop,

Je pense que tu devrais faire le flash via CC2.2 et pas CC2.4...j'ai eu pas mal de problème avec la version 2.4.

Je te propose de faire un flash par RJ45 en ayant au préalable fait un factory reset. Si cela ne marche pas, tu fais la même chose avec le null modem...je te conseille bien entendu la Doume 2.015r2 pour l'image.

Si jamais ce n'est encore pas bon, on regardera ensemble pour te trouver le infos des variables et autres  ;)
DM8000 HD PVR - HDD Western Digital Caviar Green 1 To - Graveur DVD LiteOn -
VU+ Duo - Solo2 -
iTGate TGS100 - TGS200 - TGS210 -
ET 5000 -
Plasma Pioneer Kuro PdP - LX5090H !

Hors ligne gerardlso

  • Nouveau membre
  • *
  • Messages: 7
Re: Sauvetage TGS100 SVP
« Réponse #4 le: 01 Juillet 2011 à 21:52:28 »
Merci Mike mais CC2.4 n'a eu aucun défaut en peut-être 30 flash en 2 jours.

De même un flash par RJ45 supposerait que ... je n'ai pas besoin d'aide ! L'OS serait OK.

En fin d'AM j'ai un peu progressé mais ce n'est guère satisfaisant :
- unlock des secteurs protégés de la flash
- erase toute la flash SAUF U-boot
- recharge DOUME noboot
- modif des variables d'environnement créées par défaut (puisque les précédentes ont été détruites par l'erase de la flash mais aussi lors du flash de la DOUME noboot) pour modifier :
  1) bootargs : console=/dev/null devient console=/dev/ttyS0, 115200 (le reste est inchangé)
  2) bootcmd : je laisse uniquement bootm ff04000 (soit boot l'image disponible à l'@ = Linux

Dans ces conditions, après l'Uncompress ...OK de Linux, j'ai les traces de son démarrage :
- il se déclare comme Technomate et non pas Itgate
- il boote normalement jusqu'au driver Ethernet et là il coince :

"dm9000 network device driver. $Revision: 1.46 $
dm9000ae: read wrong id 0xffffffff
dm9000ae: read wrong id 0xffffffff
found dm9000 network device."

Donc pas d'ID, je ne sais pas si le chip ne répond plus (tous bits à 1) ou si cet ID a été perdu et qu'il faut le réécrire.

Comme le Linux se déclare Technomate j'ai voulu charger celui contenu dans la dernière image DAGS la 2.0.22.

Donc re-perte des variables d'environnement et remplacement par celles contenues dans cette image (je n'ai pas changé U-boot).

Une différence importante à propos de la partition root définie dans bootargs :
- dans la DOUME (et c'est ce à quoi je m'attendais) : root=/dev/mtdblock3 rootfstype=squashfs
- dans la DAGS (et c'est doublement zarbi) : root=/dev/scsi/host0/bus0/target0/lun0/part1 et il n'y a pas de définition pour rootfstype

Bref j'ai eu beau modifier les variables, je n'ai récupéré aucun message du boot Linux, je ne sais donc pas si le driver Ethernet bloque pour la même raison.

A ce stade ce serait bien d'avoir les traces du boot Linux d'un TGS100 en bon état.

C'est facile à obtenir via DCC : connecter + telnet + entrer la commande "dmesg" qui liste alors tout ce qui aurait été listé sur la console si elle avait été connectée.

Si une bonne âme voulait bien réaliser cette opération pour moi, je crois que j'en apprendrais beaucoup, alors merci d'avance à celui ou celle qui voudra bien tenter cette manip qui ne créé aucun risque pour l'appareil.

A++

MG

Hors ligne MiKe

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 5.863
    • Doume Forum
Re: Sauvetage TGS100 SVP
« Réponse #5 le: 01 Juillet 2011 à 22:53:13 »
Re,

C'est facile à obtenir via DCC : connecter + telnet + entrer la commande "dmesg" qui liste alors tout ce qui aurait été listé sur la console si elle avait été connectée.

Si une bonne âme voulait bien réaliser cette opération pour moi, je crois que j'en apprendrais beaucoup, alors merci d'avance à celui ou celle qui voudra bien tenter cette manip qui ne créé aucun risque pour l'appareil.

Et voila ce que ça donne sur un TGS100 sous Doume 2.015r2 :

[ITGATE(TGS100) /> dmesg
th idebus=xx
IBM Redwood 4/6 IDE driver version 2.0
Probing IDE interface ide0...
probing for hda: present=0, media=32, probetype=ATA
probing for hda: present=0, media=32, probetype=ATAPI
probing for hdb: present=0, media=32, probetype=ATA
probing for hdb: present=0, media=32, probetype=ATAPI
hdb: ATAPI16V2 M1C -DAGS VER 0.10, ATAPI FLOPPY drive
Using noop io scheduler
ide0 at 0xc2054000-0xc2054007,0xc205600c on irq 25
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: DAGS ATA  Model: PI                Rev: 0.03
  Type:   Direct-Access                      ANSI SCSI revision: 00
SCSI device sda: 501760 512-byte hdwr sectors (257 MB)
sda: test WP failed, assume Write Enabled
sda: asking for cache data failed
sda: assuming drive cache: write through
 /dev/scsi/host0/bus0/target0/lun0: unknown partition table
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0,  type 0
flash mapping: 1000000 at ff000000
Flash Map rev1: Found 1 x16 devices at 0x0 in 16-bit bank
Flash Map rev1: Found 1 x16 devices at 0x800000 in 16-bit bank
 Amd/Fujitsu Extended Query Table at 0x0040
number of CFI chips: 2
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
Creating 10 MTD partitions on "Flash Map rev1":
0x00000000-0x00010000 : "ENV"
0x00010000-0x00040000 : "Logo"
0x00040000-0x00190000 : "Kernel"
0x00190000-0x00800000 : "root Suqashfs"
0x00800000-0x00fd0000 : "var jffs2"
0x00fd0000-0x01000000 : "bootloader"
0x00190000-0x00fd0000 : "root+var"
0x00000000-0x00800000 : "LOW (8M)"
0x00800000-0x00fd0000 : "HIGH (8M)"
0x00000000-0x00fd0000 : "ALL (16M)"
i2c /dev entries driver
IBM IIC driver v2.1
ibm-iic0: using standard (100 kHz) mode
NET: Registered protocol family 2
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 2048 bind 4096)
NET: Registered protocol family 1
NET: Registered protocol family 17
VFS: Mounted root (squashfs filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 80k init
Warning: unable to open an initial console.
**********************Drive info***********************
_rcutype 0
_hwtype 100
Driver CVS Relase Date 05/25/08 01:00:59 210 Test DRV
Unhandled interrupt 1e, disabled
<<<<<<<clear_repeat_timer>>>>>>
set display PAL
ioremap frame buffer base: physical = 0xa0000000 logical = 0xc3380000 size = 0x00200000
ioremap user data base: physical = 0xa0200000 logical = 0xc2072000 size = 0x00000200
ioremap rate buffer base: physical = 0xa020b600 logical = 0xc3600600 size = 0x001f4a00
video fmt = 1
install irq handler and task OK
av_proc: $Id: av_proc,v 1.2 2002/10/03 12:47:57 Jolt Exp $
hwinfo->var_info.yres_virtual 576
vulcan_fb:gra: 720x576x8, pal mode.
########## _hwtype = 100 ##########
avia_av_event: $Id: avia_av_event.c,v 1.2 2002/10/03 12:47:57 Jolt Exp $
DECOD_HOST_INT_BLOCK_READ
DECOD_HOST_INT_BLOCK_READ
DECOD_HOST_INT_CHAN_CHAN
DECOD_HOST_INT_BLOCK_READ
DECOD_HOST_INT_BLOCK_READ
<<<<<<<<<<<<<<<pic start 372>>>>>>>>>>>>>>>>
DECOD_HOST_INT_BLOCK_READ
DECOD_HOST_INT_BLOCK_READ
i=1837  Speed=100
[OPEN] DVB_DEVICE_FRONTEND_0
[OPEN] DVB_DEVICE_FRONTEND_0
SET VSW: 0 1
SET ASW: 0 0
SET VSW: 1 0
SET ASW: 1 1
SET VSW: 2 1
[ak4702_set_vsw] type sw =2 type =1
SET ASW: 2 1
[AVS] : AVSIOSFNC : 3
FP_IOCTL_POWEROFF val 0
otype <<<0>>>>
otype <<<0>>>>
pDmxfilter->para.pid = ffff
 A/V for UNLOADER_TYPE_BUCKET
otype <<<0>>>>
pDmxfilter->para.pid = ffff
 A/V for UNLOADER_TYPE_BUCKET
otype <<<0>>>>
pDmxfilter->para.pid = ffff
 A/V for UNLOADER_TYPE_BUCKET
pDmxfilter->pes_para.pesType == DMX_PES_TELETEXT.
[ERROR] DMX_PES_TELETEXT && FILTER_TYPE_PES.
[AVS] : AVSIOSFNC : 3
AUD_CHANNEL_SELECT
same same pid  50f
[AVS] : AVSIOSFNC : 1
DECOD_HOST_INT_CHAN_CHAN
<<<<<<<<<<<<<<<pic start 372>>>>>>>>>>>>>>>>
same same pid  12
same same pid  12
same same pid  12
[ITGATE(TGS100) />

 ;)
DM8000 HD PVR - HDD Western Digital Caviar Green 1 To - Graveur DVD LiteOn -
VU+ Duo - Solo2 -
iTGate TGS100 - TGS200 - TGS210 -
ET 5000 -
Plasma Pioneer Kuro PdP - LX5090H !

Hors ligne gerardlso

  • Nouveau membre
  • *
  • Messages: 7
Re: Sauvetage TGS100 SVP
« Réponse #6 le: 02 Juillet 2011 à 08:26:26 »
Bonjour et merci beaucoup Mike !

Ce qui pouvait arriver est visible : comme ton Linux va plus loin dans son démarrage que le mien, la FIFO a été remplie et ton dump montre les derniers enregistrements, les premiers ont été écrasés snif snif ! Je ne peux donc pas voir l'identification du kernel, ni l'initialisation du driver Ethernet.

Ok  on peut y arriver à la console en interrompant U-boot comme je l'ai dit : CTRL + z lorsqu'il commence à bavarder dans l'hyperterminal (cable NULL modem, hyperterminal à 11520 bauds 8 bits pas de parité comme on voit dans CC2.4). Le risque est de saturer la FIFO de l'hyperterminal... c'est la joie de la découverte des systèmes que l'on n'a pas défini.

Mais comme tu sais utiliser DCC pour faire du telnet, j'ai une autre piste :
- la flash répond à la norme MTD, chaque partition fait l'objet d'un fichier spécial type /dev/mtdblockX ou /dev/mtd/X (bloc ou char)
- les partitions MTD sont identifiées dans le log Linux juste après le message "Creating 10 MTD partitions"
- il est possible de créer un fichier binaire pour chacune des 7 premières (les autres sont des aggrégats)

exemple : "cat /dev/mtd/0 > /tmp/env.bin" revient à créer le fichier binaire env.bin dans le /tmp du démodulateur, et ce fichier contient le binaire de la partition des variables d'environnement de U-boot

Si tu veux bien créer les 7 fichiers binaires qui représentent la totalité de la Flash de ton démod, alors je devrais être capable finalement de cloner ton démod en DOUME 2.0.15r2.

L'extraction des fichiers binaires se fait par DCC + ftp et les fichiers peuvent être déposés où tu veux.

Nota : de mémoire c'est bien par le driver charactère /dev/mtd/X qu'il faut passer mais je n'en suis plus sûr, je pourrai vérifier Lundi

En tous cas Mike merci pour ton aide et j'espère que tu trouveras le temps pour ces manips.

A++

MG


Hors ligne MiKe

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 5.863
    • Doume Forum
Re: Sauvetage TGS100 SVP
« Réponse #7 le: 02 Juillet 2011 à 09:26:30 »
Je vais regarder ce que je peux faire, mais là je me prépare à partir au taf  :P
DM8000 HD PVR - HDD Western Digital Caviar Green 1 To - Graveur DVD LiteOn -
VU+ Duo - Solo2 -
iTGate TGS100 - TGS200 - TGS210 -
ET 5000 -
Plasma Pioneer Kuro PdP - LX5090H !

Hors ligne gerardlso

  • Nouveau membre
  • *
  • Messages: 7
Re: Sauvetage TGS100 SVP
« Réponse #8 le: 02 Juillet 2011 à 12:22:16 »
Courage Mike surtout qu'il fait beau aujourd'hui !

A++

MG

Hors ligne gerardlso

  • Nouveau membre
  • *
  • Messages: 7
Re: Sauvetage TGS100 SVP
« Réponse #9 le: 07 Juillet 2011 à 11:15:47 »
Finalement, j'ai testé plusieurs images selon un protocole maison.

Les test les + intéressants étaient basés sur l'off 2.0.11 et la Juliet 2.0.11 : les voyants de l'afficheur faisaient la roue et terminaient sur SET...

En raccordant sur un TV (ben oui, je flashe au bureau avec l'alim secourue... mais où il n'y a pas de TV), il y a bien la splash screen initiale Juliet, puis lorsque SET apparait sur l'afficheur, les menus initiaux de l'Itgate. Configuration réseau, configuration satellites et scan. Bon je me suis trompé dans la config Diseq mais France24 OK image et son.

Le PB c'est que le  réseau est mort, comme je pouvais m'y attendre suite au message d'IR DM9000 erroné : pas de connection, pas de ping, et finalement état des leds de l'interface RJ45 incohérent.

Il y a donc un problème matériel contrairement à ce que je pensais. Cela peut être le PHY mais aussi le contrôleur, bref je n'ai pas les moyens de réparer moi-même, et le faire faire ne serait pas raisonnable.

Je vais donc "oublier" mon TGS100 qui fonctionnait parfaitement bien pour mon usage, et compte tenu du budget, je crois bien que je vais essayer une DM800HD.

A noter pour ceux qui auraient lu ce fil que la dernière version de U-boot avec la 2.0.22 semble avoir des différences importantes avec les précédentes :
- variables ENV de U-boot stockées sur 8 secteurs de 0x1000 bytes (au lieu d'1 secteur de 0x10000 bytes...)
- cet ENV par défaut cite bien root=/dev/mtdblock3 mais en "triturant" les flèches Up/down/Right/Left (message U-boot FRONTKEY_UP ou FRONTKEY_RIGHT) il y a écrsement de ENV avec root=/dev/ide/host0/bus0/target0/lun0/part1 donc un root file system dur HDD (+ les secteurs ENV ne sont plus Protected)

Donc cette version me semble à éviter si on ne veut pas se retrouver orphelin.

Voilà je crois mon dernier message sur ce thème, bon courage à tous & A++

MG